Skip to main content
 首页 » 文章栏目 » RouterOS

ROS备份和恢复设置

2016年11月12日44700百度已收录

ROS可以通过filesbackup命令来将系统备份为二进制文件,采用FTP或在winbox中的file列表中下载备份文件,并可以通过备份文件还原路由器设置。

ROS通过export命令导出配置文件,可生成文本文件(可编辑脚本),同样使用FTP或通过在winbox中的file中下载文件,导入配置则将脚本文本文件导入路由器。
 
Reset-configuration系统复位是将所有的配置信息从ROS中全部删除掉,在做此操作前,最好先将路由器的配置备份一次。
 
注:为了保证备份不会失败,请在将备份的文件恢复到同样的的硬件配置上去。
 
系统管理
 
操作路径:/system backup
Save 指令是保存在当前配置到一个备份文件中,显示文件在/file目录中。如需要回复指定的备份文件,可以通过/system backup中的load指令载入配置,还原当前备份文件的配置。
 
指令描述:
Load name=[filename]-载入备份文件的配置
save name=[filename]-保存当前的配置到文件中
 
例如:将当前的配置保存到文件test
[admin@MikroTik] /system backup> save name=test
Saving system configuration
Configuration backup saved
 
ROS中查看保存的文件:
[admin@MikroTik] > file print
# NAME           TYPE                                SIZE CREATION-TIME      
0 skins          directory                                jan/01/1970 00:05:23
1 test.backup    backup                             7 631 jan/02/1970 00:01:5
 
导入备份文件test
[admin@MikroTik] /system backup> load name=test
Restore and reboot? [y/N]:
y
Restoring system configuration
System configuration restored, rebooting now
 
 
Winbox下配置备份和恢复
直接在files菜单下,通过backuprestore操作
161633idp0elbb8wps0e0e.png.thumb_
 
 
 
导出指令(export
Export指令用于导出脚本配置信息,这个命令可以在任何目录下执行。Export同样也可以通过file属性指定保存的文件名。可以用FTP或者进入winbox下载。
Export导出的文件是明文,且是标准的ROS脚本,所以可以进行编辑。
 
指令描述:
Hid-sensitive – 隐藏敏感参数,如密码等信息。
File=[filename]-保存的文件名称。
例如:
[admin@MikroTik] /ip address> print
Flags: X – disabled, I – invalid, D – dynamic
#   ADDRESS            NETWORK         INTERFACE                              
0   192.168.88.1/24    192.168.88.0    ether1
 
导出一个脚本文件,该文件包含了IP的配置参数:
[admin@MikroTik] /ip address> export file=ip-address
 
ROS中查看导出的文件:
[admin@MikroTik] > file print
# NAME           TYPE                                SIZE CREATION-TIME      
0 skins          directory                                jan/01/1970 00:05:23
1 ip-address.rsc script                               163 jan/02/1970 00:15:50
 
ROS5.12后新增功能export  compact命令,该命令简化了导出的参数,仅导出修改的配置,系统默认配置参数将不再被一并导出。有助于对比路由器的配置和方便导入其他路由器。
 
[admin@MikroTik] > export compact
# jan/02/1970 01:53:21 by RouterOS 5.25
# software id = MWFC-HC3L
#
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip address
add address=192.168.88.1/24 interface=ether1
 
导入指令(import
操作路径:/import
Import命令只能在根目录下使用/import file_name指令还原指定配置。这种方式适用于部分配置或者功能。
指令描述:
File=[filename]-导入的路由器配置文件
 
例如:
使用下面的指令操作导入配置文件:
[admin@MikroTik] > import ip-address.rsc
Opening script file ip-address.rsc
 
Script file loaded and executed successfully
 
Winbox里面可以查看产生的.rsc的文件:
161633tpmu7dukmlm7un27.png.thumb_
 
系统复位
操作路径:/system reset-configuration
 
这个指令将会清除掉ROS里面的所有配置,包括登陆的帐号和密码(恢复为“admin”和密码空)IP地址和其他的配置都将会抹去,在reset指令执行后路由器将会重启。RouterOS 3.0版本后,在复位ether1接口会配置默认IP地址192.168.88.1/24
 
操作命令:
[admin@MikroTik] > /system reset-configuration
Dangerous! Reset anyway? [y/N]:
y
system configuration will be rese
 
复位时可以在命令后根据实际情况加相应的参数。
[admin@MikroTik] > system reset-configuration
keep-users  no-defaults  run-after-reset  skip-backup
 
keep-users:复位时不删除管理用户帐号
no-defaults:复位后不要默认配置
run-after-reset:重置后运行相应的备份文件
skip-backup:没有任何备份


评论列表暂无评论
发表评论