另类动态域名解析,动态端口映射脚本

 梦缘人   2018-11-27 13:48   412 人阅读  0 条评论
会省钱

RouterOS 6.14开始MikroTik为RouterBOARD设备提供动态域名解析服务。即你的RB设备将自动获得一个域名,能为你经常变更的IP提供动态域名解析,让你知道如何连接自己的RB路由器。

当前Cloud仅提供两种服务:

ddns (提供IPv4外部地址的DNS域名解析,IPv6不支持)

时间同步(当NTP无法工作时,实现时间同步,精确到秒,根据UDP数据包延迟)

注意:事实上DDNS服务提供是由cloud服务器实现,所以用户必须调整防火墙策略保证能正常连接到cloud服务器

警告: 如果路由有多个IP地址或网关,精确的IP地址更新可能会出现错误!

:global webip [:resolve "xxx.sn.mynetname.net"]

:global OldIpAdd

:set OldIpAdd [/ip firewall nat get [/ip firewall nat find comment="Https"] dst-address]

:if ($webip != $OldIpAdd) do={/ip fir nat set [/ip fir nat find comment="Https"] dst-address=$webip}

:if ($webip != $OldIpAdd) do={/ip fir nat set [/ip fir nat find comment="WEB SERVER"] dst-address=$webip}

:if ($webip != $OldIpAdd) do={/ip fir nat set [/ip fir nat find comment="Radmin"] dst-address=$webip}

:if ($webip != $OldIpAdd) do={/ip fir nat set [/ip fir nat find comment="WiFi_API"] dst-address=$webip}

:if ($webip != $OldIpAdd) do={/ip fir nat set [/ip fir nat find comment="绿化大师"] dst-address=$webip}

:log info ("所映射的动态IP以修改成功,新的IP地址为:" . $webip)

QQ截图20170207022851.png

本文地址:https://www.xfnz.net/785.html
版权声明:本文为原创文章,版权归 梦缘人 所有,欢迎分享本文,转载请保留出处!

 发表评论


表情